atarionline.pl Altirra problem - Forum Atarum

Jeśli chcesz wziąć udział w dyskusjach na forum - zaloguj się. Jeżeli nie masz loginu - poproś o członkostwo.

  • :
  • :

Vanilla 1.1.4 jest produktem Lussumo. Więcej informacji: Dokumentacja, Forum.

    • 1: CommentAuthorAlex
    • CommentTime3 Nov 2009
     
    Czy ktoś jest mnie w stanie uświadomić czemu po odpaleniu Altirry 1.3 lub 1.4 ukazuje mi się biały prostokąt? Wszystko słychać, że działa, menu i reszta jest, ale zamiast obrazu Atari jest białość...
    • 2:
       
      CommentAuthorPecus
    • CommentTime3 Nov 2009
     
    W rejestrze skasuj zawartosc:
    HKEY_USERS\Software\virtualdub.org\Altirra\Pane layouts
    • 3:
       
      CommentAuthormiker
    • CommentTime3 Nov 2009
     
    Potwierdzam, że to pomaga. Miałem taki efekt po uruchomieniu którejś z nowszych wersji, bezpośrednio po używaniu starszej. Podany przez Pecusia sposób naprawił problem. :)
    • 4: CommentAuthorlaoo
    • CommentTime3 Nov 2009
     
    A ja miałem podobny problem przy próbie uruchamiania wersji skompilowanej. Ogólnie z konfiguracją UI są problemy.
    • 5: CommentAuthorAlex
    • CommentTime3 Nov 2009
     
    Dzięki! Teraz działa :-) Mała poprawka -> to jest w HKEY_CURRENT_USER
    • 6:
       
      CommentAuthorPoklik
    • CommentTime3 Nov 2009
     
    Ewentualnie wybranie opcji "Reset Window Layout" z "View" powinno dać taki sam efekt bez grzebania w rejestrze.
    • 7:
       
      CommentAuthorDracon
    • CommentTime26 Dec 2009 zmieniony
     
    Może ktoś napisać jak skonfigurować sobie ten emulator, aby odpalać rzeczy na VBXE itp. ? Umieściłem ROMy obok emulca, zaznaczyłem "PAL" i "VBXE", potem za pomocą drag'n drop ładuję i... nic (albo zwiecha albo inne nieciekawe efekty).
    Jak na razie interesuje mnie (poprawne) uruchomienie tych plików:

    1. christmasbeep.xex
    2. ns-vbxe.xex
    3. jsw_vbxe.xex

    :)
    • 8: CommentAuthortebe
    • CommentTime26 Dec 2009
     
    System -> Hardware -> 800XL
    System -> Firmware -> 600XL/800XL
    System -> Video -> PAL , VBXE
    • 9:
       
      CommentAuthorlarek
    • CommentTime23 Apr 2011
     
    W edytorze Basica (i nie tylko) klawisze kursora na klawiaturze PC działają mi jak klawisze... kursora, czyli na Atari CTRL+"kierunek". Nie chcę, żeby Altirra za mnie wciskała klawisz CTRL. Co zrobić, żeby do przesuwania kursorem należało naciskać CTRL+"kierunek", a nie tylko "kierunek"?
    • 10:
       
      CommentAuthorgalu
    • CommentTime23 Apr 2011 zmieniony
     
    Może masz włączoną windowsową funkcję pt. "klawisze trwałe" ( ->link<- ) bo nie spotkałem się z takim zachowaniem Altirry.
    W razie czego to uruchomienie Altirry z linii poleceń z przełącznikiem /resetall przywraca ustawienia domyślne programu.
    • 11:
       
      CommentAuthorlarek
    • CommentTime23 Apr 2011 zmieniony
     
    Nie, nie mam nic takiego włączonego w windowsie. Nie wiem czy mnie dobrze zrozumiałeś. Chodzi o to, że po uruchomieniu np. Basica (w Altirze) i nacśnięciu klawisza kursora na klawiaturze Peceta kursor na ekranie przeskakuje zgodnie z wciśniętym klawiszem, a wszyscy dobrze wiemy, że w Atari tak się nie dzieje, bo żeby przesunąć kursor trzeba oprócz klawisza ze strzałką nacisnąć klawisz CTRL. Altirra wciśnięcie klawisza kursora "przekłada" na atarowskie CTRL+kierunek. W Atari800Win można było ustawić sobie interpretację klawiszy kursora, a w Altirze tego nie widzę...
    • 12:
       
      CommentAuthormiker
    • CommentTime23 Apr 2011
     
    Zawsze można to zgłosić bepośrednio autorowi. Raczej nie robi oporów co do sugestii zmian (no, może z małymi wyjątkami). :)
    • 13:
       
      CommentAuthorgalu
    • CommentTime23 Apr 2011
     
    U mnie Altirra tak się nie zachowuje - żeby przesunąć kursor w BASICu (pod Altirrą) muszę dodatkowo przytrzymać lewy Alt.

    Ostatni build Altirry:
    ->link<-
    • 14:
       
      CommentAuthorlarek
    • CommentTime23 Apr 2011
     
    Lewy Alt+kierunek? Zaiście małoatarowska kombinacja ;). Uważam, że powinno być CTRL+kierunek, bo tak jest w Atari.

    Problem ze strzałkami zniknął, a w zasadzie został zamaskowany, gdy w opcjach "Input Maps" zaznaczyłem "Arrow Keys -> Joystick (port 1)". Ale to takie połowiczne rozwiązanie. Choć na razie może być :)
    Dzięki za pomoc.
    • 15:
       
      CommentAuthorlarek
    • CommentTime28 Dec 2015 zmieniony
     
    Czy wie ktoś, jak ustawić w Altirrze, aby dyskietka domyślnie była w trybie R/W, a nie R/O?
    Zaczyna mnie wkurzać, jak przy każdym uruchomieniu Rzygonia muszę wchodzić w opcje i odblokowywać zapis na dyskietce.

    edit:
    Właśnie zauważyłem, że jak odpalam najpierw Altirrę, to jest ok (dyskietka w trybie R/W), ale jak klikam w dyskietkę (pik ATR) - co powoduje uruchomienie emulatora - to dyskietka zawsze jest w trybie R/O.
    • 16: CommentAuthorxxl
    • CommentTime28 Dec 2015
     
    w naglowku ATR jest informacja czy ma to byc ATR tylko do odczytu - sprobuj moze o to altirze chodzi.
    • 17:
       
      CommentAuthorlarek
    • CommentTime28 Dec 2015
     
    Bajty (bity), które odpowiadają za ochronę przed zapisam (wg opisu pliku ATR w Atariki ) mają wartość 0. To chyba nie to.
    • 18:
       
      CommentAuthorvoy
    • CommentTime28 Dec 2015
     
    W gałęzi rejestru HKEY_CURRENT_USER\SOFTWARE\VirtualDub.org\Altirra\Profiles\00000000 też nic nie ma, co by pozwalało na ustawienie tego na sztywno. Spróbuj może napisać do Phaerona.
    • 19:
       
      CommentAuthorlarek
    • CommentTime29 Dec 2015
     
    Z tego co się doszukałem, to było już poruszane: ->link<-
    • 20: CommentAuthorodislaw
    • CommentTime16 Sep 2018
     
    dwa pytania.
    1. W niektórych grach na ekranie pojawiają się takie artefakty jak po prawej stronie. Jest sposób na to?
    2. Czy przy nagrywaniu video z "gejmpleja" można ustawić większy rozmiar niż 376x240?
    • 21: CommentAuthorodislaw
    • CommentTime16 Sep 2018
     
    ok, problem nr 1 rozwiązany
    • 22:
       
      CommentAuthorshanti77
    • CommentTime16 Sep 2018 zmieniony
     
    Ja nagrywam na fullscreenie nakładką nvidii, taki materiał po wrzuceniu na youtube chodzi w 60hz i hd.
    • 23:
       
      CommentAuthorDracon
    • CommentTime5 Feb 2019 zmieniony
     
    Panowie (i panie) mam spory problem z "ujarzmieniem" Altirry w temacie nagrywania video z działającego np. dema. ZAWSZE "wyprodukuje" mi z tego obraz rozciągnięty, panoramiczny. :(
    Próbowałem rożnych opcji i ciąglę efekt ten sam lub podobny.
    Przez to przy wgrywaniu na YT mam komunikat, że wynik będzie kiepskiej jakości.

    ALTIRRĘ mam chyba w miarę nową, odpalam to pod W10, dysponuje kartą graficzną GeForce GTX1060.
    Czy ktoś tu może poratować??? ;o
  1.  
    Spróbuj wyłączyć emulację VBXE - u mnie powodowała ona właśnie taki efekt.
    • 25: CommentAuthorkski
    • CommentTime5 Feb 2019
     
    Przed wrzuceniem na YT przeskaluj do 720p w przeciwnym razie YT wyświetla 25 klatek zamiast 50 i gorszą jakość.
    • 26:
       
      CommentAuthorshanti77
    • CommentTime5 Feb 2019
     
    Ja przełączam Altirrę na pełny ekran i wtedy skrótem klawiszowym włączam nagrywanie w sterowniku NVIDII , wystarczy później nagrany materiał wrzucić na youtube.
    • 27:
       
      CommentAuthorYosh
    • CommentTime5 Feb 2019
     
    Altirra zrzuca ładnie bezstratnie, yt wymaga konkretnej kompresji aby było dobrze i nie musiał za dużo dłubać:

    ->link<-
    • 28:
       
      CommentAuthorDracon
    • CommentTime6 Feb 2019
     
    Dzięksy za wszystkie odpowiedzi! Na pewno jeszcze potestuję nagrywanie.
    Mam tylko pytanie jakich opcji najlepiej używać w podmenu emulatora (włączyć kompresję itp.) ?

    Czy jest możliwość robienia "pauzy" w nagrywaniu pod Altirrą podczas ładowania czegoś, tak aby zminimalizować niepotrzebnie wydłużony o to czas? Czy raczej robi się to później w jakimś edytorze video?


    @shanti77
    Rozumiem, że obywasz się bez bezpośredniego nagrywania w emulca i aktywujesz nagrywanie z samej karty graficznej...
    Czy nic nie musisz tam ustawiać? Czy wychodzi oszczędniejszy rozmiar niż gdyby nagrywać spod samej Altirry?
    U mnie było tak, że 15 minut to 1 GB filmik (opcja "save video" z Altirry).
    • 29:
       
      CommentAuthorshanti77
    • CommentTime6 Feb 2019
     
    @Dracon dokładnoe tak robię, w nvidii trzeba tylko ustawić sobie jakiś skrót klawiszowy, który nie koliduje z Altirrą. Wielkość pliku jest w rozsądnych rozmiarach.
    • 30: CommentAuthormav
    • CommentTime6 Feb 2019
     
    Ja z kolei polecam Wam sprawdzić program OBS, bo sprawdza się w tej roli świetnie, można zaznaczyć region, albo okno, albo fullscreen. Bardzo dobry.
  2.  
    Potwierdzam, OBS świetnie daje radę.